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Welcome 

To 

IC Studio - ICSQL 

 

 

 

 

 
Version 1.0.0 

 

 
Welcome to IC Studio – Ultimate Database Application Development Companion from IC Soft, 

Inc.  This suite of products allow database developers to focus more on solving business problems 
as opposed to becoming expert on the database management. 
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IC Studio 
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Overview 
 
 

IC Studio is a comprehensive tool designed to help application developers be more efficient when working 
with database as they design, develop, test and support any client/server or web applications.   

 

Its friendly graphical user interface greatly simplifies the complex task of finding, examining and/or 
maintaining Database objects.  Its intuitive and comprehensive visual interface allows developers to get a 
clear perspective of a complex database.  All key server objects such as tables, views, synonyms, stored 
procedures, triggers, table privileges, functions, and indexes are few clicks away. 

 

IC Studio includes the following components: 

 

• ICSQL 

• ICObjects 

 

ICSQL 

 

ICSQL provides instant access to SQL, for the database backend programmers and DBA.  IC-SQL offers a 
point and click interface for developing complex SQL statements.  And the results of queries can be viewed 
in a spreadsheet style window.  This allows you to focus on the data you need without being an expert in 
SQL. 

 

ICObjects 

 

ICObjects provides easy viewing of any of your database objects such as Tables, Views, Synonyms, 
Stored Procedures, Sequences, Triggers, Functions, Constraints, etc.  It allows maintenance of some of 
these objects.  Its intuitive and comprehensive visual interface allows developers to get a clear perspective 
of the database. 
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Company Commitment 
 

IC Soft, Inc. was formed in January 1996, to provide development tools that today’s web / client-server 
application developers need.  Our guiding principles are: 

 

• Commitment to customers 

• Quality is not available for compromise 

• Continuous improvement for our products 

• There is no substitute for hard work. 
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To make this product better 
 

At IC Soft, Inc., we strive to make our products better.  We look forward to hearing any feedback regarding 
IC Studio.  You can contact us through any of the communications channels listed below. 

 

E-mail support@ic-soft.com 

Address IC Soft, Inc. 

21C Orinda Way, # 332 

Orinda, CA  94563 

Fax 1 (925) 253-1574 

World Wide Web www.ic-soft.com 

Office Hours Monday to Friday 8:00 A.M. to 5:00 P.M. Pacific Standard 
Time. 
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IC Soft Technical Support 
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Contacting IC Soft 
 

Before reporting a problem with the IC Soft products, please prepare the following information.  It 
is best to write this information or send us fax or email us this information prior to call. 

 

• Product serial number used for registration 

• Product name and version number 

• Operating system version (Windows 95, 98, NT, or 2000 etc) 

• RDBMS platform and its version number 

• Connectivity middle ware software 

• What you were doing when the problem occurred 

• Exact wording of any messages that appear on your screen 

• How to reproduce this problem 

 

Technical Support 

 

In order to access IC Soft products technical support, you must be a registered user. 

 

Corporate headquarters 

 

Address:  IC Soft, Inc. 

21C Orinda Way, # 332 

Orinda, CA  94563 

USA 

Telephone: 1.925.254-2731 

Fax:  1.925.253-1574 

World Wide Web: www.ic-soft.com 

Support Email:  mailto:Support@ic-soft.com 

Office Hours:  Monday to Friday 8:00 A.M. to 5:00 P.M. Pacific Standard Time 
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Getting Started 
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Technical Requirements 
  

Both ICSQL and ICObjects are 32-bit applications that operate on Windows 95 and higher and Windows 
NT 4.0 or Windows 2000. 

 

System Requirements St 

 

• 16 megabytes of free RAM (32 MB recommended) 

• Microsoft Windows 95, 98 or NT (4 and later) or Windows 2000 system 

• 15 MB of hard disk storage 

 

Oracle 

 

• 32-bit Oracle SQL*Net or Net8 

• Oracle 7.0 or higher 

• 32-bit ODBC drivers  

 

Microsoft ODBC Driver for Oracle (preferred driver) can be downloaded from the Microsoft 
Universal Data Access site at http://www.microsoft.com/Data and click on the Microsoft Data Access 
Components 2.x URL to download. 

 

Microsoft SQL Server 

 

Currently not supported. 
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To Install IC Studo 
 

If you have installed the IC Studio previously, remove the version using the Add/Remove  Programs in the 
Control Panel prior to your installation. 

 

1. Close all programs. 

2. Insert the IC Soft IC Studio  CD-ROM in your CD-ROM drive or simply click on the icstudio.exe 
downloaded from our download site found at http://www.ic-soft.com. 

3. Open the Control Panel window and click on the Add/Remove  Programs icon to start the setup. 

4. Read the information and select Next button to move forward to the User Information dialog. 

5. Enter your name and company name and click Next to proceed. 

6. Follow the setup instructions that appear on the screen to complete the installation procedure. 

7. Fill out and mail or fax your registration card to IC Soft, Inc. 
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Setup ODBC Data Sources 

 

After installing IC Studio, you must setup ODBC Data Sources in order to establish connections to your 
database servers.    

 

To establish the ODBC Data Sources, you must do the following: 

• Install the appropriate ODBC driver on the computer. 

o To download the Microsoft ODBC driver for Oracle.  Visit Microsoft Universal Data site at 
http://www.microsoft.com/data and download the latest version of the MDAC (Microsoft Data 
Access Component) software. 

• Define a data source name (DSN) by using the ODBC Data Source Administrator application which is 
accessible from the Control Panel or simply typing odbcad32.exe  from the Run command from Windows 
Start button.   

• Select the User DSN or System DSN tab. 

• To define a new DSN, click Add. 

• Select an appropriate ODBC Driver. 

• Complete the dialog boxes that are displayed and click on OK to establish the DSN. 
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ICSQL 
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General 
  

ICSQL offers a point and click interface to develop complex SQL statements.  ICSQL eliminates the need 
for the old command-line tools and allows you to focus on the data you need without being an expert in 
SQL. 

 

Today’s database developers are faced with challenge of maintaining growing amount of 
data with limited time to develop and deploy client/server and web applications.    With 
ICSQL, you can safely and efficiently manage your database. 

 

Key features 

 

• Powerful multi-document SQL editor 

• Easy-to-use Graphical User Interface (GUI)  

• Quick viewing of commo nly used database objects  

• Easy connection to several types of databases  

• Easy viewing of query result 

• Easy retrieval of the previously edited SQL files 

• Customizable features including the toolbar, colors, fonts, and others. 
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Connecting to Local Database 
 

Start ICSQL by double clicking on the ICSQL icon.  The ICSQL Login is displayed. 

 

  

 

To connect to a local database 

 

• Select a Data Source of your database from the Data Source list box. 

• Enter the server user id in the Login ID edit control of Login Information. 

• Enter the server password in the Password edit control of the Login Information. 

• Click the OK button to connect.  A Connection in Progress dialog box appears, showing the progress 
of server connection. 

 

Note that both Data Source name and Login ID information you entered here will be stored in the 
system registry so that they will be filled the information last entered in this application. 

 

To exit ICSQL 

 

• Click on Cancel button on the Login dialog or press Esc key to exit ICSQL. 
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Working with SQL-Windows 
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ICSQL Environment 

 

An overview of the ICSQL User Interface: 

 

  

 

The main focus of the ICSQL interface is the SQLWin which consists of the SQL Query Editor, Results 
Window and SQL-Designer.  The SQLWin and its SQL-Designer provide an easy to use SQL Query editor 
/ generator.  A mouse is used to control navigation and construction of SQL statements.  The tool allows 
users to issue queries and view the results in a spreadsheet style window against the tables, views and 
synonyms. 

 

SQLWin is an independent window with its own toolbar and menu.  So you can open as many SQLWin as 
possible and arrange them. 
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The following toolbar options are available in the SQLWin: 

 

Buttons Description 

  Open an existing SQL file.  The File Open dialog appears. 

  Save the changes.  The File Save As dialog appears. 

  -   Display SQL Editor  - View Query Results  

  Use the SQL-Designer.  The SQL-Designer window appears. 

  Execute the SQL statement. 

  Print SQL statement or Query Results 

  Output to HTML file.  The Export Result window appears. 

  Refresh SQL statement 

  Delete the selected data 

  Copy the selected data 

  Replace the selected data 

  Undo previous change 

  Redo previous change 

  Find a value in SQL Editor or Query Results 

  View each row at a time in the Query Results 

  View the first row 

  View the previous row 

  View the next row 

  View the last row 

  View Help 

  Close SQLWin 
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Arranging Multiple SQLWin Windows 

 

Multiple SQLWin windows can be arranged with the Tile, and Cascade options on the main Window 
menu.  Each SQLWin window can be used to perform SQL operation and view the query results as shown 
below: 
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Opening an existing SQL statement 

 

To open any one of the predefined SQL file, choose Open from the File menu or simply click on Open  
button on the SQLWin toolbar.  ICSQL displays the Open dialog box.  

 

  

 

The Open dialog box displays the contents of the current SQLWin working directory.  To change your 
working directory, click the Up One Level button or Look in the available folders and files.  To view how 
the current folder fits in the hierarchy on your computer, click the down arrow. 

 

ICSQL Recalling previously edited SQL file is possible in the ICSQL.  
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Storing Queries in a Directory 

 

ICSQL editor stores all of your SQL queries in a directory.  You can store your SQL query file in any directory you 
choose.    To store your edited SQL statement, from the File menu, choose Save  or click on the Save  
toolbar button.  The following File Save As dialog appears: 
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SQL Query Editor 

 

SQL Query Editor displays, creates or modifies a SQL statement using the standard editor. 

 

  

 

It includes the standard editing features such as Cut , Copy , Paste , Undo , and Redo .  To 
use any of the edit functions, from the Edit menu, click on the desired menu item or simply click on the 
desired toolbar button. 
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To find each occurrence of a combination of any characters in your Query Editor, from the Edit menu, 
choose Find or simply click on Find  toolbar button to proceed to Find Text  dialog window. 

 

To save your SQL statement, from the File menu, click on the Save or Save As menu item or simply click 
on the Save   toolbar button.  The File Save As dialog appears. 
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SQL-Designer 

 

To design SQL statement using SQL-Designer; 

 

1. Click on the SQL-Designer  button on the SQLWin toolbar or choose SQL-Designer from the 
Tools menu.  The SQL-Designer window is displayed. 

 

  

 

2. SQL-Designer window allows you to select the desired table for the current schema and to select one 
or more of the SQL construction options. 

• Select a table and choose the SQL Operation - SELECT, UPDATE, INSERT, DELETE, OR 
COUNT and click on one or more of the selection criteria. 
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• Click on the Execute button  to construct your SQL statement.  If any one of the SQL criteria is 
selected, ICSQL will display the SQL-Builder window. 

 

Note that clicking of the Execute button  without selecting any SQL selection criteria, ICSQL 
will return to the SQL Win Query Editor with the SQL statement with all the columns selected. 

 

• To select all of the selection criteria and proceed to the SQL-Builder, click on the Select All and 
Go  toolbar button.  ICSQL will display the SQL-Builder window to allow you further define 
your SQL statement. 

 

• Select a table and click on the Describe  button  to view Describe Object View. 

 

• Select a table and click on the Index button  to view the Index View.  

 

• Select an object and click on the Property button  to view the Object Property View. 

 

• If any of one of the selection criteria options is selected, ICSQL will display the SQL-Builder 
window to allow you to further define your SQL statement.  The SQL-Builder allows you to select 
which columns to be involved in your SQL statement as well as specifying the conditions for data 
selection. 
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SQL-Builder 

 

If any one of the selection criteria is selected in the SQL-Designer window, the SQL-Builder window is 
displayed. 

 

Specify a Set of Columns 

SQL-Builder Column Selection tab allows you to select columns to be included in your SQL statement: 

 

  

 

Group functions return results based on group of rows.  To enter group function, simply 
select a group function for the column of your choice.  Note that the group function such 
as MIN, MAX, and SUM cannot be mixed with the non-group function (regular column 
selection). 
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Specifying Conditions for WHERE Clause 

SQL-Builder allows you to construct your WHERE clause with simple mouse click as shown on the SQL-
Builder Where tab: 

 

  

 

Select a column to be included in your WHERE Clause.  Default Equal comparison operator is pre-
selected.   

Choose the comparison operator of your choice. 

If you select the BETWEEN comparison operator, Between dialog window is displayed to allow you to 
enter the beginning and ending values. 

If you select the IN comparison operator, IN dialog window is displayed to allow you to select multiple 
values. 

 

Ordering the Rows 

 

To order rows returned by your SQL statement, select Order By tab to select the column or columns from 
the columns list box and choose ordering of the selected column, Asc (ascending order) or Desc 
(descending order).  



 30 
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Specifying the Values for BETWEEN Clause 

 

Values for your SQL BETWEEN clause can be entered manually on the SQL-Builder 
Where  tab or the beginning and ending values for the BETWEEN relational operator can 
be entered or selected on the SQL-Builder Between dialog window : 
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Specifying the Values for IN Clause 

 

Values for your SQL IN clause can be manually entered on the SQL-Builder Where  tab 
or one or more column values can be selected on the SQL-Builder IN dialog window. 
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Describe Object View 

 

ICSQL allows you to display the definitions of each column in a given object (table, view, or synonyms) by 
simply clicking on the Describe Object toolbar button  from any of the windows that display it. 

 

ICSQL displays the Object Property window showing Describe tab:  

 

  

 

• Click Print  button to print the object definition. 

• Click Output to HTML  button to proceed to Export Result dialog window to export the object 
definition to HTML file. 
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Index View 

 

ICSQL allows you to display indexes associated with the table object by simply clicking on the Indexes  
toolbar button from any of the windows that display it. 

 

The following output results: 

 

  

 

To display detail information on a particular index; 

• Select an index. 

• From the View menu, choose Index Detail or click on Index Detail  toolbar 
button to view the Index Detail information. 
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Index Detail View 

 

ICSQL allows you to display the detail information on a particular index by simply clicking on the Index 
Detail  toolbar button from the Index View window. 

 

The following output results: 

 

  

 

• To display index detail, from the View menu, choose Index Detail or click on the 
Index Detail  toolbar button. 

• To display index columns, from the View menu, choose Index Columns or click 
on the Index Columns  toolbar button. 
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• To print index detail information, from the File menu, choose Print or click on the 
Print  toolbar button. 
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Object Property View 

 

ICSQL allows you to display the object summary information such as total number of rows for the selected 
object (table, view, or synonyms) by simply clicking on the Object Property toolbar button  from any 
of the windows that display it. 

 

The following output results: 
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Performing Explain Plan Command 

 

To optimize your SQL Statement, Explain Plan feature is available in ICSQL.  After your SQL statement 
is constructed, simply click on the Explain  toolbar button to view the results from Explain Plan 
command against your SQL statement. 

 

  

 

Because Explain Plan statement requires the result table to hold its output, ICSQL will create Plan_Table 
under your schema if such a table does not already exist. 
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To examine the execution plan produced by an EXPLAIN PLA N statement, you must have the privileges 
necessary to query the output table. 
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Find Text 

 

To find a text in the SQL text in the Query Editor, from the Edit menu, select Find, or 
click on the Find  toolbar button, the Find dialog is displayed. 

 

  
 

Enter the text you want to search in the Find What text box.  

Click Next button to begin the search. 

Click Replace  to proceed to Replace Text.  
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Replace Text 

 

To replace a text in the SQL text in the Query Editor, from the Edit menu, select Replace, the 
Replace dialog is displayed. 

 

  

 

In the Find What text box, enter the text that you want to search for. 

In the Replace With text box, enter the replacement text. 

Select the search option of your choice. 

Click Find Next, Replace, or Replace All. 

Click Close to exit. 
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Display Constraints 

 

ICSQL allows you to display the integrity constraints for a given table by simply clicking 
on the Constraints toolbar button  from any of the windows that display it. 

 

  

 

An integrity constraint is a rule that restricts the values for one or more columns in a table. 

 

To view detail information for each constraint, simply click on the constraint name with your mouse or use 
Up and Down arrow key. 
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Working with QuickView 
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QuickView 
 

QuickView (Short for Quick Object View) of the ICSQL tool provides easy viewing of key database 
objects such as tables, views, and synonyms. 

 

  

 

Click on the Selection  toolbar button to view the list of the database objects such as tables, views, or 
synonyms.  Click on an icon on the QuickView List Bar on the left side of the window to select the desired 
database object. 

 

The following objects are currently supported by the QuickView. 
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• Tables 

• Views  

• Synonyms . 

 

In the QuickView Selection window, click one of the following buttons on the toolbards:  Large icons  , 
Small Icons  , List  , or Details   to change the appearance of the selection view. 

 

• To sort the objects by Name, Schema, Created, Modified, Status, or Comments, simply click on the 
header column. 

 

• Select an object in the selection list and click on the View Object  toolbar button to view the object 
or simply double-click on the object to proceed to Viewing Results.  

 

• To see the definitions of each column in an object, select an object and click on Describe Object  
toolbar button. 

 

• To see the indexes for a table object, select a table object and click on Show Index  toolbar button. 

 

• To view the constraints for a table object, select a table object and click on Constraints  toolbar 
button. 

 

• To see the object property information such as name, type, creation date, modification date, status, and 
size (total number of rows), select an object and click on Property  toolbar button. 

 

• Double-click on each row or click on the View Current Row  toolbar icon to proceed to Row-
Browser. 
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Working with Query Results 
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Viewing Results 

 

The output from your SQL query can viewed in the result view shown here. 

 

  

 

• Double-click on each row or click on the View Current Row {bmct viewrow.bmp} toolbar button to 
proceed to Row-Browser. 

• Navigation between records in the result view can be accomplished using the following toolbar 
buttons: 

• Click on First Row  toolbar button to position to the first row. 

• Click on Previous Row  toolbar button to position to the previous row. 

• Click on Next Row  toolbar button to position to the next row. 
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• Click on Last Row  toolbar button to position to the last row.  

• Click Print  button to print the object definition. 

• Click Output to HTML  button to proceed to Export Result dialog window to 
export the object definition to HTML file. 
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Row_Browser 

 

When viewing results in ICSQL tool, you can click on the View Current Row toolbar button   to view 
each row at a time as shown below: 

 

  

 

• Click Print  button to print the object definition. 

• Click Output to HTML  button to proceed to Export Result dialog window to export the object 
definition to HTML file. 

 

Navigation between records can be accomplished using the following toolbar buttons: 
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• Click on First Row  toolbar button to position to the first row. 

• Click on Previous Row  toolbar button to position to the previous row. 

• Click on Next Row  toolbar button to position to the next row. 

• Click on Last Row  toolbar button to position to the last row.  
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How to Find A Value 

 

To find a value in the result view, select Find from the Edit menu or simply click on the 
Find  toolbar button.  ICSQL displays the Find dialog. 

 

  
 

Enter the data value you want to search for in the Find What text box. 

Select the Search Column from the Search drop-down list box. 

Select the Match if drop-down list box. 

Choose Find First or Find Next button to begin the search. 
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Saving Results to HTML format 

 

To export results of your query result to HTML file, choose Output to HTML from the File menu or 
simply click on Output to HTML file  button on the SQLWin toolbar.  The Export Result window is 
displayed. 

 

  

 

Choose the desired export options and click on OK button to produce HTML file in the designated 
location. 

 

The saved HTML file can be viewed by opened by browser of your choice as shown 
below: 
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ICObjects 
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Introduction to ICObjects 
 

ICObjects provides easy viewing of any of the database objects such as Table, View, Synonym, Stored 
Procedure, Sequence, etc.  It also allows maintenance of some of these objects.  Its intuitive and 
comprehensive visual interface allows developers to get a clear perspective of the database. 

 

ICObjects manages 

• Tables 

• Views 

• Synonyms  

• Stored Procedures 

• Packages 

• Indexes 

• Functions 

• Sequences 

• Snapshots  

• Triggers 

• Roles, Table Privileges 

• Constraints 

• More… 

 

Key features 

 

• Easy-to-use Graphical User Interface (GUI)  

• Object Editor makes management of database objects easier than ever 

• Easy connection to several types of databases  

• Easy viewing of database objects  

• Customizable features including the toolbar, colors, fonts, and others. 
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Logging ICObjects 
 

Start ICObjects by double clicking on the ICObjects icon.  The ICObjects Login is 
displayed. 

 

  

 

To connect to a local database 

 

• Select a Data Source of your database from the Data Source list box. 

• Enter the server user id in the Login ID edit control of Login Information. 

• Enter the server password in the Password edit control of the Login Information. 

• Click the OK button to connect.  A Connection in Progress dialog box appears, showing the progress 
of server connection. 

 

Note that both Data Source name and Login ID information you entered here will be stored in the 
system registry so that they will be filled the information last entered in this application. 

 

To exit ICObjects 

 

• Click on Cancel button or press Esc key to exit ICObjects. 
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Working with ICObjects 
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ICObjects Environment 

 

The ICObjects main window is where you create the new schema objects, edit / view existing objects 
using the following windows: 

 

• Object Property window is used to  

o View schema object data for tables, views, and synonyms. 

o Describe schema objects. 

o View indexes for the table objects. 

o View object properties. 

• Object Editor window 
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ICObjects main window allow you to quickly view any of the database objects and to manage some of the 
objects.  Its intuitive and powerful graphical user interface allows developers to get a clear perspective of 
the database. 

 

The following toolbar options are available in the ICObjects: 

 

Buttons Description 

  Connect to database data source 
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  View selected object 

  Describe object 

  Show index  

  Display constraints 

  Display object information such as Owner, Name, Created Date, Modified Date, 
Status and Size. 

  Delete an object 

  Change the appearance of the Object Viewer using Large Icons 

  Change the appearance of the Object Viewer to use Small Icons 

  Change the appearance of the Object Viewer to use List 

  Change the appearance of the Object Viewer to use Details  

  Display Options Dialog 

  Display Help information 

  Exit ICObjects 
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Using ICObjects Editor 
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Overview of ICObjects Editor 

 

The ICObjects incorporates its own editor that enables you to view and maintain your database objects with 
ease.   

 

  

 

It includes the standard editing features such as Cut, Copy, Paste, Undo, and Redo.  To use any of the edit 
functions, from the Edit menu, click on the desired menu item or simply click on the toolbar button. 

 

The following toolbar options are available in the ICObjects Editor: 

 

Button Description 
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 Create a new script 

  Open a script file 

  Execute a script and save to database. 

  Save the active script with its current name.  If you have not assigned the script 
with filename, the Save As dialog  box is displayed. 

  Print a script file 

  Refresh editor 

  Cut the selection from the opened script and save it on the clipboard 

  Copies the selection to the clipboard 

  Inserts what’s on the clipboard 

  Search a string in the open scrip. 

  Undo 

  Redo 

  Display Options Dialog 

  Display Help information 

  Close Object Editor 
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Using ICObjects Property 
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Using ICObjects Property 

 

The ICObjects Property window displays schema data: 

 

  

 

The ICObjects Property window provides description of schema objects: 
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The ICObjects Property window displays indexes on the table objects: 

 

  

 

The ICObjects Property window also displays the object properties such as owner, name, created timestamp, modified 
timestamp, object status, and total number of rows for the selected schema object. 
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